1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X11 weirdness

Discussion in 'GIMP for Mac' started by guy noir, Jul 12, 2009.

  1. guy noir

    guy noir New Member

    Joined:
    Jul 8, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I downloaded and successfully installed Gimp 2.6.6 and X11 1.1.1, upgraded X11 to version 1.1.3. After playing with GIMP a few times X11 behaves strangely. Now, I cannot quit. If I quit GIMP, all I have is a gray screen. I have to force quit X11 to get out. I can leave GIMP via on-line help, and quit X11 from the dock. If I launch X11 alone, I get a gray screen and have to force quit. So it seems that the problem is not with GIMP but with X11.

    I am asking this question here, because I couldn't find an answer at Apple.com.
    Any ideas?

    Thank you.
    Guy Noir

    PS I am running OSX 10.4.11 on a G5 iMac
     
  2. ~suv

    ~suv Member

    Joined:
    May 13, 2009
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Indeed.

    It appears that you turned on the 'Full Screen' mode. Use 'Command+Option+A' to leave full screen mode, then open X11 Preferences > Output and uncheck 'Enable the Enter Full Screen menu' to disable the X11 root window.

    hth, ~suv
     
  3. guy noir

    guy noir New Member

    Joined:
    Jul 8, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    ;D That did the trick. Thanks.
     
  4. Chou

    Chou New Member

    Joined:
    Sep 11, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    also worked for me but still no luck opening Gimp :(
    both X 11 and Gimp stay open for a second and then close again
     
  5. Chou

    Chou New Member

    Joined:
    Sep 11, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    when i try to run it from terminal i get

    Last login: Wed Sep 16 11:37:08 on console
    Welcome to Darwin!
    vc-41-5-51-59:~ Kadiatou$ /Applications/Gimp.app/Contents/MacOS/Gimp; exit
    The application 'gimp-2.6' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    logout
    [Process completed]
     

Share This Page