1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Re: Stability issues

Discussion in 'GIMP for Mac' started by Auria, Mar 22, 2008.

  1. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    by "myself", I mean I downloaded it from the gnomesite and not something the wilber-team provided
     
  2. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    okay, *relief*

    hehe try the one in our SVN, I think (hope) you will find it better
     
  3. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    and how exactly do I download the SVN?
     
  4. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Ok sorry I thought you knew.

    Command is :
    Code:
    svn checkout https://darwingimp.svn.sourceforge.net/svnroot/darwingimp darwingimp
    You'll need SVn installed of course... you can install it from macports or from http://downloads.open.collab.net/binaries.html
     
  5. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    The new (improved) afterhours looks good. Two (minor) things I don't like though.

    1. The menubar is browner than the rest of the windows
    2. No small size in toolbox
     
  6. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Yeah menus are still a bit too brown for me too... when i have time i'll try playing with it ( but you can too ;) i have no GTk experience whatsoever so anyone here knows as much as i do )

    as for the small size in toolbox, i have absolutely no idea what you mean
     
  7. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    toolbox. you know, the icons...
     
  8. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Well on my computer I still have the choice between large and small icons... if that's what you mean
     
  9. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I don't... weird.
     
  10. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    maybe check in Gimp.app/Contents/Resources/share/gimp/2.0/themes, you should have both "Default" and "Small" there
     
  11. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    hmm. I do, but I can't seem to select to use the small theme. From where would that be?
     
  12. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    that would be in Preferences, there is a Theme section
     
  13. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    All I see in that menu is:

    Default
    greyscale
    raleigh
    afterhours
    emacs
     
  14. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    You some stuff there that's not installed by default... try going to ~/Library/Application Support/Gimp, and clean-up the "themes" and "themerc" files... also maybe check that the "gimprc" there does not override theme search paths
     
  15. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I deleted the Gimp folder in application support, reinstalled Gimp and it worked :) thanks
     
  16. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    I commited various themes improvements to SVN - menus will be less brown, and scrollbars will look cleaner
     
  17. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Ever since I deleted the Gimp-folder in application support, Gimp doesn't remember my settings. At least not the "View-settings" (in the menubar). what to do
     
  18. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Hmm I see no reason... make sure write access if correctly set... otherwise try removing the entire ~/Library/Application Support/Gimp directory (or is that what you did?)
     
  19. andreasw

    andreasw Member

    Joined:
    Mar 17, 2008
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Yep. that's what I did
     
  20. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    When you run GIMP, is it re-created?
     

Share This Page