1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help. Lines do not save or stay on image

Discussion in 'GIMP for Mac' started by Rottee, Jul 14, 2011.

  1. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I am new here and new to GIMP. I have a Mackbook Pro Running OS X 10.6.8
    and the version of GIMP is 2.3.6

    I am trying to draw straight lines as a border around an image that has a black background. I have used the path tool,
    and pencil. When I use the path tool or pencil, when I release the mouse, or with paths, when
    I click off of the image, the lines are gone too.

    What do I need to do to draw simple lines and have them saved to my image? I have watched some online
    videos, on youtube, and in the videos, when a line is drawn, and the shift key released, the line stays on the canvas.
    As soon as I release the shift key, the line disappears.

    Please help


    Thank you
     
  2. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    Oo Weird ... I'll sum it up for you again:

    - Click somewhere on the canvas with the painbrush tool (or the pencil)
    - Hold the shift (/alt/ctrl/command, depending on your settings) key down and move your mouse to another location.
    - Click again on that location

    This should give you a perfectly straight line.

    If you want to use the path tool, make your path and then go to the path tool options:
    [​IMG]
    From there, select "Stroke Path" and select your desired options for the stroke.


    By the way I'd suggest you update your Gimp version to 2.6 :eek:
     
  3. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the help,

    I am doing exactly as you direct, and have tried the pencil, paint brush, and path.
    When I release the shift key after clicking on the location I moved the cursor to, the line disappears.

    If using the path tool, once I have the box drawn, I do click on stroke path, but when I click out of that tool,
    the lines go away. I am doing exactly as you say, could it be a setting or layer or something simple that
    has been overlooked?

    My mistake about the version, X11 is 2.3.6 and Gimp is 2.6 on my laptop.

    Thank you
     
  4. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    Hmm .. have you tried re-installing Gimp? That fixes 90% of the bugs ...
     
  5. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    We'll,

    Yesterday when I couldn't get this to work, I looked for an update, and there was one so I installed it. Should I uninstall and re-install? I think I will go ahead and do that instead of waiting for a reply and then then narrow it down from there if that doesn't do it, since this is your first suggestion.

    Thank you, and I will report back, but if you think the update I did should of taken care of it, then what do you
    suggest next?

    Thank you
     
  6. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Uninstalling and re-installing fixed it!!!! :)

    Worked on the first try.

    I thank you very much for answering my post and helping me get this going again.

    Rottee
     
  7. Arzoroc

    Arzoroc Moderator Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    2,201
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Germany
    Glad I could help :)
     
  8. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    You were of great help, You got my stalled project moving again. Thank you.
     
  9. Rottee

    Rottee New Member

    Joined:
    Jul 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My success was short lived. When I re installed GIMP yesterday, I quickly opened the application and an image
    and used the path to draw my lines. I had no trouble with this at that time. Now that I am back to my project, I am encountering
    the same issue of the lines not being saved, or disappearing when I click onto a new tool.

    Could this be a matter of how I am using layers or which layer the lines are being drawn on? I tried another
    test and when I open an image and select the path tool, and draw a box, then click onto another
    tool, the lines remain in place, as I assume they should.

    What I am doing when this process does not work, is opening a template of a book cover, then opening a image of
    the picture I want on the cover, both of these are .png, however I have tried using the picture in .png and .bmp

    I then re-size the picture to fit on the template, in another layer. The next step is to use the rectangle select to create a border around
    the outside edge and fill it in with the bucket tool. I then add some text, and then move onto the path tool, which is where I encounter the issue.

    Any ideas or suggestions to help me figure this out?

    Thanks again,

    Rottee
     

Share This Page