1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Packagers wanted

Discussion in 'GIMP for Mac' started by Auria, Mar 31, 2008.

  1. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Well the option would be to create a second file, by adding e.g. a "-2" suffix. However maybe it's just better to keep that for a next build since managing all releases and changing all links does take a little time
     
  2. chachi

    chachi New Member

    Joined:
    Apr 2, 2008
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    I agree.  Next time around I'll be on top of things though for sure!  :D

    Thanx for all your time and patience!  I greatly appreciate it!
     
  3. chachi

    chachi New Member

    Joined:
    Apr 2, 2008
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    Gimp 2.4.5_1 Leopard PPC

    What gimp2 releases are you primarily interested in?  I've just updated my Gimp.app to the latest MacPorts version (gimp2 @2.4.5_1+darwin_9).  Should I add this build or wait for more of a "point" release?


    P.S.
    This time around I did not have to add the session.d folder.  The scripts worked perfectly.
     
  4. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Well I have no clue what is the change in this macports revision

    If you think it can be of interest then go ahead and do the build, you know how and it's your time that you're spending ;)
     
  5. chachi

    chachi New Member

    Joined:
    Apr 2, 2008
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    Submitted...

    I just added the new build (GIMP-2.4.5_1-20080405-Leopard-PowerPC.dmg) to sourceforge.  I'm currently working on a Panther PPC version.  I have lots of family members and friends who are still running Panther and would love to use the gimp.  I'm just trying to make it as easy for them as I can.  :)
     
  6. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    cachi, if you can make a Panther version, I'm sure lots of people will love you  :D


    PS: If you wish to update the links on the downloads page, Im pretty sure you have the rights to do so (if you know a bit of HTML... otherwise I'll do it myself) I've attached a screenshot showing how you can reach our website.
     

    Attached Files:

  7. chachi

    chachi New Member

    Joined:
    Apr 2, 2008
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colorado
    The more the merrier!!!  :D  I'll definitely try to keep ya posted with my Panther progress.

    I must have the rights cause I just updated the downloads page for ya.  8)  At least that's one less thing you have to deal with in your busy schedule.
     
  8. theonehorst

    theonehorst Member

    Joined:
    Nov 29, 2007
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Home Page:
    Is here noone who wants to do a Tiger/Intel build? Where are kl3ks and Cloud and all the old guys :(
     
  9. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I have an intel Mac with Tiger. Do you still need a packager? What happened to the packager who worked on 2.2.4?
     
  10. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    we definitely are in need of a 10.4 Tiger build, it hasn't been updated for quite some time and does not habe all latest improvements, therefore if you can provide one it would be great :) I am not sure what happened on the packager(s) that previously did it... sometimes people are just busy. We don't really have official packagers for each platform, we only take the build of whoever makes and contributes it first :)

    The build instructions can be found here : http://darwingimp.sourceforge.net/buildgimp.html
     
  11. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    OK, I'll try to follow the instructions. How should I upload it when I am done?

    EDIT: There are a lot of tar files in /downloads/MacPorts-1.6.0 . Which one should I use? I presume it is not in one of the dmg files. Anyways, I am trying MacPorts-1.6.0.tar.gz for now.
     
  12. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
  13. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    "install gimp2" step took forever and it eventually returned: 

    DEBUG: Executing org.macports.activate (p5-getopt-long)
    --->  Activating p5-getopt-long 2.37_0
    Error: Target org.macports.activate returned: Image error: /tmp/skl/Gimp.app/Contents/Resources/lib/perl5/5.8.8/Getopt/Long.pm is being used by the active perl5.8 port.  Please deactivate this port first, or use the -f flag to force the activation.
    Warning: the following items did not execute (for p5-getopt-long): org.macports.activate
    Error: The following dependencies failed to build: libgnomeui gnome-icon-theme icon-naming-utils p5-getopt-long p5-xml-simple p5-xml-namespacesupport p5-xml-sax p5-xml-parser gnome-keyring gconf glib2 gtk2 atk cairo fontconfig freetype libpng render xrender gtk-doc docbook-xml-4.1.2 xmlcatmgr docbook-xsl gnome-doc-utils docbook-xml docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 iso-codes py25-hashlib openssl python25 libxml2 libxslt py25-gobject py25-libxml2 py25-numeric rarian getopt intltool gnome-common jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff orbit2 libidl libgcrypt libgpg-error libtasn1 libbonoboui dbus xmlto dbus-glib gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo libglade2 libgnome esound audiofile libgnomecanvas gail libgtkhtml libmng autoconf help2man p5-locale-gettext libtool m4 automake lcms librsvg libcroco libgsf libwmf poppler poppler-data py25-gtk py25-cairo py25-numpy fftw-3 g95 odcctools subversion apr apr-util db44 sqlite3 gawk gmake readline neon
    Error: Status 1 encountered during processing.


    How can I fix this?
     
  14. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    crap. still more macports problems.  :(

    i asked for help on the macports IRC channel... someone told me you should try this :

    Code:
    sudo ~/src/macports/Gimp.app/Contents/Resources/bin/port -f activate p5-getopt-long
    then you should be able to resume the gimp build by entering the same command as previously (the one that ends with "gimp2 +x11")

    EDIT: just for information/reference, the bug is reported here : http://trac.macosforge.org/projects/mac ... cket/14731
    EDIT 2 :and here http://trac.macosforge.org/projects/mac ... cket/14853
     
  15. theonehorst

    theonehorst Member

    Joined:
    Nov 29, 2007
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Home Page:
    I had this p5 error once or twice. just repeat building. a some time it will build....
     
  16. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Sorry guys, I was out of the house for a while. Anyways, Auria, I tried your steps, but now I get this:

    ld64 failed: in libpython2.5.a(__.SYMDEF), not a valid ppc64 mach-o file
    /usr/bin/libtool: internal link edit command failed
    make: *** [libpython2.5.dylib] Error 1

    Warning: the following items did not execute (for python25): org.macports.activate org.macports.build org.macports.destroot org.macports.install
    Error: The following dependencies failed to build: libgnomeui gnome-keyring gconf gtk2 gtk-doc gnome-doc-utils iso-codes py25-hashlib python25 libxml2 libxslt py25-gobject py25-libxml2 py25-numeric rarian getopt intltool gnome-common jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff orbit2 libidl libgcrypt libgpg-error libtasn1 libbonoboui dbus xmlto dbus-glib gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo libglade2 libgnome esound audiofile libgnomecanvas gail libgtkhtml libmng autoconf help2man p5-locale-gettext libtool m4 automake lcms librsvg libcroco libgsf libwmf poppler poppler-data py25-gtk py25-cairo py25-numpy fftw-3 g95 odcctools subversion apr apr-util db44 sqlite3 gawk gmake readline neon
    Error: Status 1 encountered during processing.


    Why does it think this is supposed to be a PPC fie?
     
  17. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    OK, after a bit of bug searching, I updated my Xcode to 2.5 from 2.2, now building it works fine as long as I run

    sudo ~/src/macports/Gimp.app/Contents/Resources/bin/port -f activate p5-getopt-long

    after "gimp2 +x11" step once I hit that error message about p5-getopt-long and then repeat "gimp2 +x11" command. Even the ghostcript was fine, so I did not have to re-build it. BTW, it took hours to get through this step. Is that normal? I am used to compiling things in a matter of minutes.

    Now I am at "svn checkout" step. I'll keep you posted...
     
  18. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Great  ;D the hard part is done

    Yes it's normal it took hours, GIMP itself is huge, let alone all of its dependencies (including GTK, cairo...) lots of stuff is needed to run GIMP
     
  19. theBB

    theBB New Member

    Joined:
    Apr 12, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Oh, you hid this important info from me. "Hours" is normal, eh... I feel misled. :)

    OK, the package is done except for dmg part. I'll try to finish it up tonight. In the meantime, I've opened up an account at sourceforge, with the user name theBB.
     
  20. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Sorry, didn't want to look like i'm hiding stuff from you... we're just so used to doing it that it seems obvious to us ;) Still, if you're willing to continue contributing GIMP packages in the future, next times it will probably be much less long since most stuff would be already installed

    I will give you file releases access permissions when i got home tonight so you can upload your dmg once it's done

    Great job, we'll now have up-to-date packages for everyone  :D
     

Share This Page