1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gimp wont start...

Discussion in 'GIMP for Mac' started by mano.aus, Aug 18, 2008.

  1. mano.aus

    mano.aus New Member

    Joined:
    Aug 18, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Process: gimp-2.2 [3009]
    Path: /Applications/Gimpshop.app/Contents/Resources/bin/gimp-2.2
    Identifier: gimp-2.2
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: Gimp [2988]

    Date/Time: 2008-08-19 02:32:55.777 +1000
    OS Version: Mac OS X 10.5.4 (9E17)
    Report Version: 6

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /usr/X11/lib/libfontconfig.1.dylib
    Referenced from: /usr/X11R6/lib/libXft.2.dylib
    Reason: Incompatible library version: libXft.2.dylib requires version 3.0.0 or later, but libfontconfig.1.dylib provides version 2.0.0

    New to using a mac, so im pretty clueless, any help would be greatly appreciated, thanx.
     
  2. sglider12

    sglider12 Active Member

    Joined:
    Nov 30, 2007
    Messages:
    3,610
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    I work at Best Buy as a Digital Life Sales Associa
    Location:
    Aubrey, Texas
    Home Page:
    Hmm... maybe this should be in the wilber-loves-apple section (the mac section for gimp). I'll move it to the support section.
     
  3. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    First, i see you're using Gimpshop 2.2. This is an outdated version, try using our new Gimp 2.4 builds instead : http://darwingimp.sourceforge.net/download.html

    To make them run, follow the install instructions written there. You'll need to install XQuartz
     
  4. mano.aus

    mano.aus New Member

    Joined:
    Aug 18, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanx buddy, its all good now!
     
  5. gebby

    gebby New Member

    Joined:
    Aug 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem with the latest gimp version 2.4.6 for leopard PPC

    Process: gimp-2.4 [428]
    Path: /tmp/skl/Gimp.app/Contents/Resources/bin/gimp-2.4
    Identifier: gimp-2.4
    Version: ??? (???)
    Code Type: PPC (Native)
    Parent Process: sh [419]

    Date/Time: 2008-08-19 14:17:03.883 +0200
    OS Version: Mac OS X 10.5.4 (9E17)
    Report Version: 6

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000001, 0x000000008fe0105c
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /usr/X11/lib/libXrandr.2.dylib
    Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk-x11-2.0.0.dylib
    Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 4.0.0 or later, but libXrandr.2.dylib provides version 3.0.0

    I try to install x11 xquartz 2.3.0, but it don't work no terminal appear,
    i try now with the 2.2.3 xterm work but gimp dont work
    I installed x11 user (optional package )

    if someone can help me , it will be fine thanks
     
  6. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    gebby, what do you mean exactly by "but it don't work no terminal appear" ? No terminal is supposed to appear when you open gimp the normal way.

    The error message really means your X11 is too old. So i would need to know why you cannot install the latest XQuartz.
     
  7. gebby

    gebby New Member

    Joined:
    Aug 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    With x11 2.2.3 i have a terminal xterm but gimp dont work

    with x11 2.3.0 i have no terminal, "xterm Xt error: Can't open display: 0.0", gimp dont work too



    20/08/08 08:37:10 [0x0-0x5b05b].org.gimp.Gimp[2928] (gimp-2.4:2938): Gtk-WARNING **: Locale not supported by C library.
    20/08/08 08:37:10 [0x0-0x5b05b].org.gimp.Gimp[2928] Using the fallback 'C' locale.
    20/08/08 08:37:10 [0x0-0x5b05b].org.gimp.Gimp[2928] cannot open display:
    20/08/08 08:37:36 login[2947] USER_PROCESS: 2947 tty??
    20/08/08 08:37:36 login[2947] DEAD_PROCESS: 2947 tty??
    20/08/08 08:37:36 [0x0-0x57057].org.x.X11[2855] xterm Xt error: Can't open display: 0.0

    Now Openoffice doesnt work too.

    have you a idea ?
    thanks

    I think there are some problems with x11
     
  8. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    This sounds like problems with XQuartz indeed. I think you should report them to the XQuartz team, they will know much better than me how to fix them. (especially if OpenOffice is broken too, this indicates it's not a GIMP problem)

    Alternatively you can probably install Apple's X11 as per the instructions but it's a bit more complicated and doesn't work for everyone. I would try contacting the XQuartz folks.
     
  9. gebby

    gebby New Member

    Joined:
    Aug 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It's difficult to know where is the problem, i try to find on the web but without success

    may be these lines can explain it :
    Xquartz work, but no xterm

    Last login: Thu Aug 21 08:51:12 on ttys000
    penot03:~ gwen$ /Applications/Utilities/X11.app/Contents/MacOS/X11 ; exit;
    X11.app: main(): argc=1
    Waiting for startup parameters via Mach IPC.
    X11.app: Could not connect to server (DISPLAY="0.0", unsetting). Starting X server.
    X11.app: Launching /usr/X11/bin/startx:
    argv[0] = /usr/bin/login
    argv[1] = -fp
    argv[2] = gwen
    argv[3] = /bin/sh
    argv[4] = -c
    argv[5] = /usr/X11/bin/startx
    Last login: Thu Aug 21 09:01:26 on ttys001
    font_cache: Scanning user font directories to generate X11 font caches
    font_cache: Updating FC cache
    xauth: creating new authority file /Users/gwen/.serverauth.412

    X11.app: do_start_x11_server(): argc=6
    argv[0] = /usr/X11/bin/X
    argv[1] = :0
    argv[2] = -nolisten
    argv[3] = tcp
    argv[4] = -auth
    argv[5] = /Users/gwen/.serverauth.412
    InitConnectionLimits: MaxClients = 255
    Xquartz starting:
    X.Org X Server 1.4.2-apple5
    Build Date: 20080715
    Launchd socket fd: -1
    Sync Extension 3.0
    Popen: `"/usr/X11/bin/xkbcomp" -w 1 "-R/usr/X11/share/X11/xkb" -xkm "-" -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xkbcomp are not fatal to the X server" "/var/tmp/server-0.xkm"', fp = 0xa005c374
    Pclose: fp = 0xa005c374
    XKB: Loaded /var/tmp/server-0.xkm, defined=0x7f
    (dix) initialising device 0
    (dix) initialising device 1
    (dix) initialising device 2
    (dix) initialising device 3
    (dix) initialising device 4
    (dix) enabling device 0
    (dix) enabling device 1
    (dix) enabling device 2
    (dix) enabling device 3
    (dix) enabling device 4
    font_cache: Done

    waiting for X server to begin accepting connections .
    AllocNewConnection: client index = 1, socket fd = 1
    AllocNewConnection: client index = 2, socket fd = 7
    AllocNewConnection: client index = 2, socket fd = 7
    xterm Xt error: Can't open display: 0.0

    and
    echo $DISPLAY
    0.0
    echo $PATH
    /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

    I dont know how to contact Xquartz, there are some mailing list only for develloper
    thanks
     
  10. Auria

    Auria Member

    Joined:
    Mar 16, 2008
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
  11. gebby

    gebby New Member

    Joined:
    Aug 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you Auria,
    now the problem is solved
    As william write in x11 mailing list, i ve a file where the value display is fixed to 0.0

    it's for a lyx appllication, i create a environnement.plist in my profile and fix display value to 0.0

    Thank you to take time, and now gimp works :D :D

    i ve just an other question, :idea:

    where can i modify the default background color of gimp windows ?
    In a previous gimp version i d modified a gtkrc file theme, the backgroud was dark with this file, but now since the 2.4.5 i cant modified it, by default the colour is fixed like the default theme. my theme works partially and have no effect on the window backgroud colour (menu bar ) :question:

    thank
     
  12. gebby

    gebby New Member

    Joined:
    Aug 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i found the solution for the backgroud color

    this color is fixed by the content/etc/gtk 2.0/gtkrc files
    the first line set a theme: gtk-theme-name = "Afterhours"
    I rename temporaly the file and now my theme works

    :D
     

Share This Page